Skip to content

PHP5! Finally

Dear Reader,

I finally took the plunge to PHP5! I learned 1 very important lesson that anyone coding in PHP or administering servers running PHP should know. NEVER EVER EVER upgrade to the latest version if you are running Zend*. Zend lags the php releases by a few days. In my case, I am using ZendOptimizer. The latest version 2.5.10a does not work with PHP 5.1. There is a hint that 2.5.13 is in the works if you know where to look but I could only find the FreeBSD version. So after tinkering for a couple of hours I dropped back to the 5.0.x tree.

Oh, also, when moving from 4.x to 5.x, I had to uninstall and reinstall a pecl extension I had. Upgrade won’t work because pecl thinks it knows better. Why would you want to rebuild the version that is already there? (grrrr) Since there is no force option, I did the only thing I could think of…uninstall and reinstall.

Anyhow, for those of you curious, current versions of DirectAdmin and Installatron work with 5.0.x. (Granted I’ve not done much in the way of testing but they do come up.)

Squirrelmail is hopelessly hosed though. (That’s why I’m not reading my email right now)

Anyhow, back to the grind.

Until next time, I’m counting down the days.

(l)(k)(bunny)

=C=